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How do I open a word list for study?

This lesson shows how to open a word list for study in Sona Vocabulary Assistant.

Open Sona Vocabulary Assistant.

Double-click on the program icon for Sona Vocabulary Assistant.
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Option #1: click on "Open a list."

In the Menu screen click on "Open a list."
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Option #2: Choose "File > Open..."
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Choose a list in the dialog box that appears, then click 'Open.'

Sona word lists are ordinary text files with special formatting. Such lists end in .txt and should be
opened from Sona's main menu.
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The word list is loaded.

You'll see the name of the file at the upper right. Sona Vocabulary Assistant has now generated the
activities listed at right in the Menu screen.
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Tips on Using the Review List Screen

This lesson describes how to review vocabulary and supporting materials in a word list.

After opening a word list, click on "Review List."

We're assuming that you've opened a word list and can see the list name at upper right, as well as a list
of activities below.
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Spend some time in the "Review List" screen.

1) Click to select a word in the list.
2) When you see a speaker icon, click to hear the word or phrase.
3) Click to see a video clip.
4) Click to send the word as a search term to Google.
5) Click to enlarge the thumbnail image.
6) Click the underlined text to visit web links.
Not all lists will have give this much information for each item, but it's good practice to explore all the
resources provided, including sounds, web links, images, video, or internet searches for more
examples.

Sona Vocabulary Assistant Manual - 10



Tips on Using the Flashcard Screen

This lesson gives suggestions on how to get the most out of the Flashcard screen.

Overview of Features

1) Click here to hear the word or phrase pronounced.
2) Click here to hear the example in context.
3) Click here or press "f" to flip the virtual flashcard.
4) Click here or press "r" to remove a card from the virtual stack. This does not remove the item from
the word list.
5) Click here or press "p" to return to the previous item.
6) Click here or press "n" to go to the next item.
7) Click here to hide examples in context.
8) Click here to switch the language you're prompted in first.
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How Best to Use The Flashcard Screen

-Repeat out loud, don't just read silently to yourself.
-Be sure to work in both direction, both into and out of your target languages.
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Creating and Editing Word Lists
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How do I create a new list?

This lesson shows how to create a new word list in Sona Vocabulary Assistant.

Choose File > New.

Go to the File menu and choose New, or press command-N (Windows: control-N).
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The Edit List screen appears.

In this screen you can type in (or drag in from a word processor or web page) the text you need for
target words, translations, examples, and notes.
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Type in the information for a target word.

Use tab to move to the next field; shift-tab to move to the preceding field.
1) Click the '+'  button to add another item.
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Save your work.

It's a good idea to save your work every few minutes by choosing File > Save, or pressing command-s
(Windows: control-s).
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How do I edit an existing list?

This lesson describes how to add to or make changes to an existing list.

Under the "File" pulldown menu choose "Edit a list."

From the Menu screen, go to the File menu and choose 'Edit a list,' or press command-e (Windows:
control-e).
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Select a list.

Select an existing list and click "Open."
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The list opens in the "Edit List" screen.

You can now change or add information in the list, or add new words. To type in a field, click on it, or
use the tab key to move from field to field. Don't forget to save your work now and then!

Watch the screencast.

You can also watch this screencast on adding examples and notes to existing lists.
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How do I move from word to word while editing a list?

This lesson describes several ways to move around between word sets while editing a list.

Click the "next item" or "previous item" buttons.

1) Click to go to the previous item.
2) Click to go to the next item.
You can also use keyboard shortcuts: press the down arrow for the next word; press the up arrow for
the previous word.
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Drag the navigation slider.

When you drag the slider (1), a box appears with a word; release the slider when you see the word you
need. This is also a handy way to go quickly to the first or last item in the list.
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Click the List View button (1) to open a list of all the words in a list in a separate
window.

Click on a word in the List View window (2) to go to the entry screen for that word.
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How do I add notes and examples of usage?

This lesson shows how to include notes and examples of usage in a word list.

Choose "Edit a list."

From the Menu screen, go to the File menu and choose 'Edit a list,' or press command-e (Windows:
control-e).
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Select a list.

Select an existing list and click "Open."
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The list opens in the "Edit List" screen.

You can now change or add information in the list, or add new words. To type in a field, click on it, or
use the tab key to move from field to field. Don't forget to save your work now and then!
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How do I add sounds?

This lesson shows how to add sounds to your word lists. You can use one of three methods to link to
an entire sound file.

From the Menu screen choose File > Edit List.
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Method #1: In the Edit List screen, type the name of a sound file into a sound field.

Click the "sound 1" field and type into it to link a sound with the target word. To link a sound with one of
the examples, or with notes on usage, type into the "ex sound 1," "ex sound 2," or "notes sound" fields.

It's best to avoid using accented characters or other diacritics in the names of your media files: here
we're using the sound file name "o thuaidh.mp3" for the word "ó thuaidh."
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Method #2: Drag a sound file from the Finder (XP/Vista: from Windows Explorer) into
the proper field.

Use methods #1 and #2 when you want to link to entire sound file.
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Method #3: Click a "choose sound file" button.

This brings up a dialog box in which you can choose a sound file.
1) Select a sound file for the target word.
2) Select a sound file for the first example.
3) Select a sound file for the second example.
4) Select a sound file for the notes.

To link to a segment of a sound file, see "How do I link to a segment of a sound or
movie?"
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How do I add images?

This lesson shows how to link a word to an image.

From the Menu screen choose File > Edit List.
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Method #1: Type the name of an image file into the "image 1" field.
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Method #2: Drag an image file from the Finder (XP/Vista: from Windows Explorer) into
the "image 1" field.
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Method #3: Click the "choose image file" button.

This brings up a dialog box in which you can choose an image file.
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How do I add movies?

This lesson shows how to add links to movies that you distribute with your list. Use these methods
when you want the user to have access to entire movie file. 

From the Menu screen choose File > Edit List.

Method #1: Type the name of a movie file into the "movie" field.

Method #2: Drag a movie file from the Finder (XP/Vista: from Windows Explorer) into
the "movie" field.

To preview the movie, click the 'preview movie' button.

The movie opens in a separate window.

To link to a segment of a movie file, see "How do I link to a segment of a sound or
movie?"
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How do I link to a segment of a sound or movie?

This lesson shows how to link a word to a segment of a sound or movie file.

From the Menu screen choose File > Edit List.
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The Edit list screen appears.
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Choose FrameChecker > Open FrameChecker.

The FrameChecker utility lets you select the start and end points for a segment of a sound or movie file. 
In this example, we'll link the example of usage to the segment of the sound file in which it occurs so
that when the student clicks on the phrase, just that portion of the sound file is heard.
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The FrameChecker window opens.

Before using FrameChecker you'll need to load a sound or movie.
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Drag a sound or movie file onto the black box, or click "select a file."

1) You can also select a sound or movie file by clicking "select a file" and choosing a file in the dialog
box that opens.
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The file is now loaded into FrameChecker.

You see the name of the file in the black box, and a set of controls appears below.
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You can drag the slider in the control bar to move around in the sound or movie.

1) When you move the slider (1) or pause the sound/movie, the current frame number appears in blue
(2).
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When you've found the beginning of the segment you want, click the 'segment start'
button or press the 's' key.

1) When you click this button, playback starts, and the current frame is stored as the starting cue for the
segment.
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When you come to the end of the segment, click the 'end segment' button or press the
'e' key.

1) When you click here, playback pauses and the current frame is set as the end of the segment.
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The start and end points for the segment are now set.

In this screenshot the starting cue is at frame 11098, and the ending cue is at frame 13273.
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Click the "preview" button or press 'p' to preview the segment.

Previewing the segment lets you make sure you're satisfied with the start and end cues.

Sona Vocabulary Assistant Manual - 46



Adjust the start cue if necessary.

1) Click here, or press the right arrow key, to move the start cue forward in increments of about 1/3 of a
second.
2) Click here, or press the left arrow key, to move the start cue backward in increments of about 1/3 of
a second.
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Adjust the end cue if necessary.

1) Click here, or press command-right arrow (Windows: control-right arrow), to move the end cue
forward in increments of about 1/3 of a second.
2) Click here, or press command-left arrow (Windows: control-left arrow), to move the end cue
backward in increments of about 1/3 of a second.
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Paste the settings into the Edit List screen in Sona Vocabulary Assistant and continue
to the next item.

1) Click or press command-1 (Windows: control-1) to paste the filename and cue points into the sound
1 field.
1) Click or press command-2 (Windows: control-2) to paste the filename and cue points into the
example sound 1 field.
1) Click or press command-3 (Windows: control-3) to paste the filename and cue points into the
example sound 2 field.
1) Click or press command-4 (Windows: control-4) to paste the filename and cue points into the notes
sound field.
1) Click or press command-5 (Windows: control-5) to paste the filename and cue points into the movie
field.

This will automatically advance you to the next item in the Edit List screen and return you to
FrameChecker to set another pair of cue points.
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It's worth learning the keyboard shortcuts!

With a little practice you can zip through your list, setting cue points without lifting your hands from the
keyboard. This sequence of key presses will become second nature:
s - starts playback, sets start point
e - pauses playback, sets end point
p - previews segment
      if necessary: right or left arrows - adjust starting point 
      if necessary: cmd + right or left arrows - adjust ending point (Windows; control + right or left arrow
keys)
cmd + 1, 2, 3, 4, or 5 - pastes information into Edit List, automatically advances to next item
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How do I add a web link?

This lesson shows how to add web links to a word list.

Under the "File" pulldown menu choose "Edit a list."

From the Menu screen, go to the File menu and choose 'Edit a list,' or press command-e (Windows:
control-e).
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Select a list.

Select an existing list and click "Open."
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The list opens in the "Edit List" screen.
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Highlight the text you want to serve as a link.
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Choose "Text > Create Hyperlink."
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Type or paste in the web address, and click OK.
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The highlighted text is now underlined, showing that it is a hyperlink.

Remember to choose "File > Save" to save the change. Note that in the current version of Sona
Vocabulary Assistant, the link will be active in the Review List screen, but not in the Edit List screen.
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Open the file from the Menu screen and click "Review List."

The link is now active in the Review List screen. Clicking the link opens the web address in the default
browser.
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Where should I keep my files?

This lessons shows where you can keep your word lists and supporting media.

Word lists are text files.

Word lists are plain text files with tagged text. They are always stored external to Sona Vocabulary
Assistant. You can keep them anywhere you like on your computer, or also on a USB drive or CD.

Anyone who has struggled to open a fifteen-year old word processing document from the mid-90s
knows that programs, and file formats, come and go. We feel that storing word lists in plain text files
gives your lists their best chance to lead a long and productive life, whether with future versions of
Sona Vocabulary Assistant, other vocabulary programs, or even future operating systems.
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Media files (sounds, images, movies) are also separate files.

Sona word lists refer to your media files, but do not incorporate them. When you distribute a list with
sounds, images, or movies, be sure to distribute the media files as well.
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Media files should be in a folder/directory named "media" in the same place as the
word list that uses them.

If you have several lists that use the same media files, you can keep multiple lists together, as shown
here.
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What are some tips for creating lists quickly and efficiently?

This lesson contains tips based on the experiences of the designer of Sona Vocabulary Assistant, Dr.
Curtis Ford, who has created dozens of lists for his students and for his own study.

Enter target words and translations first.

Type in the basics of your list first, just the target words and translations.

Enter examples and notes next.

Remember that you can drag in text from other programs such as word processing documents or web
browsers.

Add sounds and images when after entering text.

Organize your image and sound files by putting them in a folder named "media" in the same place
where your word list is saved. That makes it easy to add sounds, images, or movies by dragging the
files into the Edit List screen.
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Link to segments of sound or movie files after all the words have been entered.

FrameChecker makes your workflow especially easy when your target words and definitions have
already been entered in your list; by using keyboard shortcuts and letting FrameChecker auto-advance,
you can link to segments for an entire list without lifting your hands from the keyboard.
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Importing Word Lists
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How do I import a word list from a word processing document?

This lesson shows how to import word lists from tab-delimited text files created in a word processor. In
steps 1 through 4, we'll see how to make sure that a list is saved in the proper format using Bean, a
free word processor for Mac OS X (http://www.bean-osx.com).

Create or open a word list in a word processor.

Use a separate line for each new word. 
Don't use the columns feature in a word processor, just use a single tab to separate items in a line.
The items in each "column" should match: in this example the first "column" has new vocabulary, the
second has translations, the third has the names of sound files to be included, and the last has
examples of usage.
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Under the File menu, Choose "Save as.." Then select "Text Document (.txt)"  and click
"Save."

Be sure not to save your list in .doc or .rtf format.

Be sure to save as plain text despite warnings about lost formatting.

Most word processors will remind you that saving as plain text will not preserve text formattng or other
document properties.

Sona Vocabulary Assistant Manual - 66



After saving in plain text format, your list may look different.

Information about where the tab stops are set has been discarded, but that's OK! Sona List Converter
just needs a tab to separate items in a word set, and line breaks to separate word sets.

Open Sona List Converter.

Double-click on the Sona List Converter icon.
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Check the settings for your list.

1) Since the order of columns in our German list was target word, translation, sound, and example, we'll
choose those options in the popup menus. We leave items 5 and 6 set to "none."
2) Check the 'unicode' box for languages like Russian, Hindi, or Hebrew that do not use the Latin
alphabet.
3) When this box is checked, List Converter will append " Sona" to the end of the file name; for
example, when converting "German list.txt," a copy in Sona format will be saved as "German list
Sona.txt."
4) When this box is checked, the folder where your converted list is saved will be opened in the
Finder/Windows Explorer.
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Click on "Convert."

This will bring a dialogue box where you can choose the list. 

Choose the tab-delimited list and click "Open."
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Sona List Converter creates a new list in the proper format.

List Converter copies your list, converts it list to Sona format, appends " Sona.txt" to the name, and
opens the window where the new list has been saved.
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How do I import a word list from a spreadsheet?

This lesson shows how to import word lists from tab-delimited text files created by a spreadsheet
program. In steps 1 and 2, we'll see how to make sure that a list is saved in the proper format.

Create or open a word list in a spreadsheet program.

The items in each column should match: in this example column A has new vocabulary, column B has
translations, column C has the names of sound files to be included, and column D has examples of
usage.
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Under the File menu, Choose "Save as.." Then select "Text (Tab delimited)" format and
click "Save."

Sona Vocabulary Assistant Manual - 72



Open Sona List Converter.

Double-click on the Sona List Converter icon.

Check the settings for your list.

1) Since the order of columns in our German list was target word, translation, sound, and example, we'll
choose those options in the popup menus. We leave items 5 and 6 set to "none."
2) Check the 'unicode' box for languages like Russian, Hindi, or Hebrew that do not use the Latin
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alphabet.
3) When this box is checked, List Converter will append " Sona" to the end of the file name; for
example, when converting "German list.txt," a copy in Sona format will be saved as "German list
Sona.txt."
4) When this box is checked, the folder where your converted list is saved will be opened in the
Finder/Windows Explorer.

Click on "Convert."

This will bring a dialogue box where you can choose the list. 
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Choose the tab-delimited list and click "Open."

Sona List Converter creates a new list in the proper format.

List Converter copies your list, converts it list to Sona format, appends " Sona.txt" to the name, and
opens the window where the new list has been saved.
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Troubleshooting
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I tried choosing "File > Edit list.." but got an error message.

In version 1.0.1 and earlier, choosing "File > Edit list.." worked only from the menu screen.

Download version 1.0.21 or higher.

You can see which version of Sona Vocabulary Assistant you have by looking at the bottom right of the
menu screen. You can also check for updates by choosing "Help > Check for updates..."

If you can't get an updated version for some reason, a workaround for versions 1.01 and earlier is to be
sure to return to the Menu screen before choosing "File > Edit list.." 
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I double-clicked a word list and just saw a window with strange codes.

Double-clicking on a word list opens the list in a word processor, rather than in Sona Vocabulary
Assistant.

In the current version of Sona Vocabulary Assistant, word lists should be opened from
the Menu screen in Sona Vocabulary Assistant, not from the Finder (Windows Exporer).

See also "How do I open a word list for study?"
To edit a word list that already exists, see "How do I edit an existing list?"
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